[GMG-Devel] GStreamer 1.0

ayleph ayleph at thisshitistemp.com
Thu Feb 19 23:01:37 EST 2015


On Thu, Feb 19, 2015 at 09:50:34PM -0600, Christopher Allan Webber wrote:
> Boris Bobrov writes:
> 
> >
> > Now I tend towards the second option: Use GStreamer 1.0 by default and provide 
> > a way to fallback to 0.10. This option might have ugly implementation: a 
> > script to fallback to 0.10 with sql tables renames and a script to revert the 
> > fallback in some future when we drop 0.10 completely, again with sql tables 
> > renames. It also looks error-prone to me.
> >
> > What do you think?
> 
> Thanks again Boris for all your hard work on this!  It's thrilling to
> have it in master at last. :)
> 
> (I'll leave it up to others to decide the 0.10 thing ;)  But if the
> feature is available by Monday, we can support both for 0.8.0!)

I'm very excited about this as well! I am very much in favor of making gst-1.0 the default backend. As for also supporting the 0.10 thing, I'm less sure. I am sympathetic to users who can't use gst-1.0 for some reason; in fact, I was one of them until Boris helped me debug a problem with python2 packages on Arch Linux. Would there be any benefit to keeping a gst-0.10 branch up-to-date with master, or is that just as much trouble as supporting gst-0.10 in the same branch as master?


More information about the devel mailing list